SSL Certificate Expiration on Main Server
Incident Report for Falls Technology Group
Resolved
Our team has acknowledged that this problem has been solved. We have detected stability in the installation of our new certificate.
Posted Jul 31, 2022 - 09:08 CDT
Monitoring
Our team has confirmed the correction of this error and the reinstallation of a new certificate onto our server. We are monitoring it's performance over the next few hours to confirm that the Certificate is working properly.
Posted Jul 31, 2022 - 06:34 CDT
Update
Our team is still working with cPanel, Inc. to resolve this issue. At this stage we have not yet successfully implemented a solution to repair this error. Stand by for further updates. We will provide them as soon as we have them.
Posted Jul 30, 2022 - 14:57 CDT
Update
Our team is conferring with our cPanel vendor to determine the cause of our inability to regenerate certificates for our clients.
Posted Jul 30, 2022 - 12:06 CDT
Update
Our team is working on installing a new certificate and validating the certificate prior to installation into the cPanel/WHM services running on d01-kh.ftghost.us. We expect this generation to take about 15 minutes and installation to take place shortly after. We will post updates when we have them.

We have identified the root cause of this certificates expiration and have performed the necessary updates to correct this problem from occurring in the future. Currently we are working with our technical team to expedite SSL certificate generation.

Our technical team has identified a deeper issue that is causing our cPanel server to not properly renew certificates from the cPanel store. We are working on installing a custom SSL certificate to resolve this problem.
Posted Jul 30, 2022 - 11:31 CDT
Identified
The SSL Certification for d01-kh.ftghost.us as been listed as expired as of 7/28/2022. We are working to install a new SSL certificate to resolve these problems.
Posted Jul 30, 2022 - 11:30 CDT
This incident affected: Hosting Regions (Atlanta (d01-kh.ftghost.net)) and Core Services (cPanel Portal, WHM Portal, Email Services (POP/IMAP/SMTP), FTP Services).